darksky

Dark Sky API wrapper for nodeJS

npm install darksky
2 downloads in the last day
11 downloads in the last week
25 downloads in the last month

Node.js Dark Sky API wrapper

Build Status

About

A Node.js module for integrating with the Dark Sky API. You must acquire an API key to use it.

Installation

The project is hosted on npm

npm install darksky

Usage

Create a client and then call one of the exposed methods. See the Dark Sky API for details.

var darksky = require("darksky");
var client = darksky.Client("mykey");

client.forecast('37.8267','-122.423', 
    function(err, data) {
        if (err) {
            console.error(err);
        }
        process.stdout.write(data);
    }
);

Copyright (c) 2012 Aaron Westendorf. See LICENSE for further details.

npm loves you