lodashinexpress

Enables lodash templates in express 2 and 3. Derivative work off of uinexpress project by Harald Rudell.

npm install lodashinexpress
6 downloads in the last week
9 downloads in the last month

lodashinexpress

Enables lodash templates in express versions 2 and 3.

Derivative work based off of uinexpress library that enables using underscore as a rendering engine for express.js

Usage

in your express app.js, for express 3:

app.configure(function () {
  app.engine('html', require('lodashinexpress').__express)
  app.set('view engine', 'html')
});

in your express app.js, for express 2:

app.configure(function () {
  app.register('html', require('lodashinexpress'))
  app.set('view engine', 'html')
});

Notes

  • An alternative is to use ejs in the browser, see the module ejsinbrowser
  • Original project used as a reference: uinexpress
npm loves you