q-require

(out-of-service) asynchronous CommonJS require module loader for Node and browsers

npm install q-require
10 downloads in the last week
13 downloads in the last month
npm loves you