ss-livescript

LiveScript wrapper for SocketStream 0.3

npm install ss-livescript
4 downloads in the last week
9 downloads in the last month

LiveScript (JS) wrapper for SocketStream 0.3

Allows you to use LiveScript files (.ls) in your SocketStream project.

Instructions

Add ss-livescript to your application's package.json file and then add this line to app.js:

ss.client.formatters.add(require('ss-livescript'));

NOTE: when you want to require client side modules written in LiveScript, remember to add the .ls extension. E.g. in entry.js:

require('/app.ls')

prelude-ls

This wrapper only includes the base LiveScript language library. If you want to use prelude-ls in your client then:

place prelude.js in client/code/system

add 'system' folder to code section of your client definition (in /app.js)

# require prelude in your client code, here attached to window, but select your own target
require \prelude . installPrelude window

Credits

Based on the ss-coffee wrapper by the core SocketStream team.

npm loves you