uberlevel

A lmdb wrapper (level-lmdb with a cooler name)

npm install uberlevel
6 downloads in the last week
12 downloads in the last month

Uberlevel

This is a convenience package that bundles the current release of LevelUP and lmdb and exposes LevelUP on its export.

Use this package to avoid having to explicitly install lmdb when you just want plain old LevelDB from LevelUP.

var level = require('uberlevel')

// 1) Create our database, supply location and options.
//    This will create or open the underlying LevelDB store.
var db = level('./mydb')

// 2) put a key & value
db.put('name', 'Level', function (err) {
    if (err) return console.log('Ooops!', err) // some kind of I/O error

    // 3) fetch by key
    db.get('name', function (err, value) {
        if (err) return console.log('Ooops!', err) // likely the key was not found

        // ta da!
        console.log('name=' + value)
    })
})

Contributors

Level, including LevelUP & lmdb, is only possible due to the excellent work of the following contributors:

Rod VaggGitHub/rvaggTwitter/@rvagg
Kenan SulaymanGitHub/kenansulaymanTwitter/@kenansulayman

Copyright (c) 2012-2013 Level contributors (listed above).

Level is licensed under an MIT +no-false-attribs license. All rights not explicitly granted in the MIT license are reserved. See the included LICENSE file for more details.

npm loves you