webant-handler-less

A handler for the webant module for LESS requires.

npm install webant-handler-less
12 downloads in the last month

node-modules-webant-handler-less

Require LESS files with webant

Installation

$ npm install webant-handler-less

Usage

Ensure the less handler is present in your webant configuration file. For example:

{
    "entry":"src/js/main.js",
    "dest":"build/main.js",
    "handlers":["less"]
}

You may now require LESS files:

require("../path/to/styles.less");

See the webant module for more information.

Settings

compress

Can be either true or false (default). Controls whether the compiled CSS is compressed.

Tests Build Status

Ensure phantomjs is installed and in your PATH, then run:

$ npm test
npm loves you